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Crystal Reports 2020

的基本應用技巧



Systems and Information Management Section CloudSAMS

下載工作坊教材

https://cdrcloudsams.edb.gov.hk
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Systems and Information Management Section CloudSAMS

工作坊內容
1. 報告管理

◼ 報告範本 上傳下載流程 和庫存功能

2. CloudSAMS 內的 Crystal Reports 2020
◼ 連繫 CloudSAMS 的 Sybase 資料庫伺服器

◼ 修改 CloudSAMS報告範本流程

3. 更新至 Crystal Reports 2020 後五個常見問題

4. 報表設計技巧(使用相同大小及對齊功能及其他)

5. 練習(一) 修改班別名單報告 (熟習修改範本流程)

6. 練習(二) 製作學生名單
◼ 連接資料庫並提取所需資料

◼ 靈活地顯示報告表內容

➢ 篩選資料錄、排序、建立群組、 加入公式、函數

7. 練習(三) 製作每月學生生日名單 (自學部份)
4
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Systems and Information Management Section CloudSAMS

報告類別及模組主要功能

6

◼ 報告類別:統計/分析報告

◼ 檢視學生表現和發展

◼ 提供決策及管理資訊

◼ 「報告管理」模組的主要功能

◼ 下載/編修範本

◼ 存庫

設置在各模組內
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模擬中一派位排名表、統一分配學額統計

缺席報告（依原因、依班別、依次數）、
不同學年 / 月份缺席統計

獎懲追蹤報告（依班別、學生、事件）

校內成績平均分和及格百分比分析（依級別 / 科目）、
首末五名學生統計、最進步學生清單

學生課外活動概覽、統計及表現

香港學科測驗成績分析及比較（與全港學生）

歷年公開試的成績分析

檢
視
學
生
表
現
和
發
展

系統報告類別
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系統報告類別

8

班別學額資料

科目資料（必修、選修、科目組別、跨班別科目）

學生所屬家居區議會分區、減免學費、學社、年齡及
性別分析、宗教、非華語學生統計及特殊教育詳情

教職員履歷、 訓練分析報告

教職員缺席紀錄、病假/代課結餘

財政狀況及年結報告、固定資產登記冊

提
供
決
策
及
管
理
資
訊



Systems and Information Management Section CloudSAMS

報告輸出格式及範本

9

使用Crystal Report 

軟件建立系統範本

◼ 報告輸出格式

◼ PDF

◼ WORD

◼ EXCEL

◼ RICH TEXT

◼ 報告範本

◼ 系統提供範本

▪ 用戶編製範本
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下載及編修報告範本
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使用Crystal Report 

軟件修改範本
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上載用戶編製報告範本
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上載用戶編製報告範本
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Systems and Information Management Section CloudSAMS

存庫 (報告存檔)

14

(2024)
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(2024)
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存庫

16

可按模組及報告名稱搜尋已存檔之報告

只有「網上校管系統管理員」或
「校長」用户組的成員可查看所有
存庫內的報告
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Crystal Reports 軟件

18

Crystal Server 2013
(安裝在CloudSAMS伺服器)

Crystal Reports 2013
(安裝在一部CloudSAMS工作站)

◆ 每間安裝了 CloudSAMS 的學校也應備有兩個Crystal 

Reports 軟件 : Crystal Server 2013 及 Crystal 

Reports 2013

◆ Crystal Server 2013 是安裝在 CloudSAMS 伺服器，
用來產生報表；而 Crystal Reports 2013 則安裝在
一部 CloudSAMS 工作站，用來修改、建立報表範本

部分學校
已在雲端升級
至2020 2020
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ODBC (Open Database Connectivity)

19

◆ 安裝了 Crystal Reports 2020(CR 2020) 的 CloudSAMS 工作
站也應安裝了Sybase SQL Anywhere 17 ODBC 驅動程式及
配置好所需的 ODBC Settings

◆ 基於保障系統的穩定及安全，

◆ 於2018年至 2021年完成了將 網上校管系統遷移至雲端平台的

學校，2023年 1月 1日起將不能使用ODBC聯繫至雲端平台

◆ 於2022年將網上校管系統遷移至雲端平台的學校，遷移後即無

法使用ODBC聯繫至雲端平台

◆ CR 2020 可透過 Windows 內置的 ODBC 工具與用戶下載的
CloudSAMS 的資料庫連繫，繼而可讀取資料庫檔案，接着
便可編修全新的範本、修改舊範本及預覽範本
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ODBC (Open Database Connectivity)

20

◆ 如果學校需重裝該 CloudSAMS 工作站，可聯絡 貴校
的學校聯絡主任取得安裝檔案

◆ CloudSAMS 的 Sybase 資料庫伺服器預設了三個帳號：
1. genuser

2. stfuser (可瀏覽教職員資料表格)

3. fmpuser (可瀏覽財務資料表格)

◆ 如學校把密碼更改了，而又忘記了密碼，要盡快致電
CloudSAMS 求助台 (tel: 2166 1150) 尋求協助
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ODBC (Open Database Connectivity)

21

CloudSAMS 伺服器

ODBC Crystal Reports 2013

CloudSAMS 工作站

Sybase

資料庫伺服器
原本

現在

CloudSAMS 伺服器

資料庫

學校伺服器
資料庫

下載

ODBC Crystal Reports 2020

CloudSAMS 工作站
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本地資料庫伺服器設定

22

有關詳細內容，

可參閱 CDR 上的

參考文件

https://cdr.websams.edb.gov.hk/Files/Sys_sec/Sys_operation/Local%20DB%20Server%20Setup%20Guide%20for%20Schools.pdf
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本地資料庫伺服器設定（於學校伺服器）

◼ 下載資料庫

◼ 複製資料庫至學校伺服器内

23
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本地資料庫伺服器設定（於學校伺服器）

◼ 在記事簿中輸入以下文字，並儲存為 bat 檔

◼ 啓動以上 bat 檔 /啓動Sybase資料庫

24

set SQLLOCALE=Charset=UTF8;Language=ENGLISH;CollationLabel=UTF8

start C:\"Program Files"\"SQL Anywhere 17"\Bin64\dbsrv17.exe -qs -n 
"websams_{SUID}" -ec SIMPLE -sf cmdshell -gb maximum -gss 32M -gna 1 -gm 100 
-gt 8 -gtc 8 -cl 20%% -c 30%% -x tcpip{PORT=3268} 
C:\websams\websams_{SUID}.db -n websams -gk all -m
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查找 SUID (4位數字) 的方法

方法一: 使用SQL查找SUID

◼ 在CloudSAMS 資料管理 > 資料選取編修，按<自編資
料選取>

◼ 輸入<資料選取名稱> 、<資料選取說明>及<SQL語句>

select suid from tb_sch_school where schyear = 2024

25



Systems and Information Management Section CloudSAMS

查找 SUID (4位數字) 的方法

26



Systems and Information Management Section CloudSAMS

查找 SUID (4位數字) 的方法

◼ 方法二: 在CloudSAMS系統保安 >  雲端服務管理 > 
網上校管系統管理查找SUID

27

只有相關用户組的用戶可使用資料管理或
系統保安模組
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本地資料庫伺服器設定（於工作站）

◼ 修改ODBC設定（例如：Host的IP地址）

◼ 修改後，測試能否連接成功

28



Systems and Information Management Section CloudSAMS

修改 CloudSAMS報告範本流程

29

1. 從 CloudSAMS「報告管理 >範本 >編修範本」下載範本

2. 在 CloudSAMS 工作站使用 Crystal Reports 2020修改範
本 (透過 ODBC 預覽或連結其它表格)

3. 用「報告管理 >範本 >上載範本」功能，上載範本至
CloudSAMS，再作預覽測試

1,2

3

CloudSAMS 伺服器 CloudSAMS 工作站
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更新至 Crystal Reports 2020 後五個常見問題

I. 如何調整範本中的文字方塊大小

II. 如何刪除範本中的空行

III. 如何修正資料錄排序

IV. 如何修正範本中的中文亂碼

V. 如何刪除報表中的LOGIN ID: genuser

30

針對以上5項，在教學環節內，
會逐一講解如何處理以上問題。

有關詳細內容，

可參閱 CDR 

上的參考文件

https://cdr.websams.edb.gov.hk/Files/Sys_sec/Sys_operation/Points%20to%20Note%20for%20Upgrading%20of%20WebSAMS3.1%20v1.0.pdf
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Systems and Information Management Section CloudSAMS

插入文字及修改文字屬性

32

按鈕或功能表 Insert > Text



Systems and Information Management Section CloudSAMS

I. 調整範本中的文字方塊大小

33

問題二：文字重疊問題一：列印時文字消失

解決方法：點選文字方塊旁邊的調節點，調整高/闊度，或移動
文字到適當位置。

調整完高/闊度後，
留意文字方塊內的
文字對齊方式與其
他文字方塊一致。
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IV. 如何修正範本中的中文亂碼

34

在預覽時，正常顯示中文字。當CloudSAMS系統執行時，中文字顯示為方格。

解決方法：點選方塊，在上方工具列 選擇中文
字體。或按右建選擇Format Field，在Font頁內，選擇字體
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插入直線與框線

35

按鈕或在功能表選

Insert > Line / Insert > Box
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II. 如何刪除範本中的空行

36

表格由直線/橫線組合而成，可利用刪除和調整長度
功能去除多餘的空行。

刪除橫線

縮短直線

效果：
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II. 如何刪除範本中的空行 (續)

37

以系統報表R-STA005為例，Blank_Line子報表已含有格線。

可以刪除下層

區段 (section)

多餘的空行。

刪除區段
旁邊的線。

刪除
倒三角形

標記
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插入圖片

38

按鈕或功能表 Insert > Picture
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設定日期格式

39

選擇所需日期時間格式
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複製物件格式

40

按鈕或功能表 Format > Format Painter
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使物件相同大小

41

先點選要相同大小的物件，再用工具列>格式>相同大小去執行
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對齊(或排列)物件

◆通過移動或排列一些物件使報表美觀、整齊

◆在此介紹可以達到此效果的三種方法

➢利用尺規上的三角形標記

➢調校格線大小(Grid Size)

➢利用「工具列 > 格式 > 對齊」的功能

42
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對齊(或排列)物件 – 方法一

43

1. 先在欲排列整齊的位置上點一下尺規，顯示倒三
角形標記
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對齊(或排列)物件 – 方法一

2. 再用滑鼠把物件移至三角標記附近

44



Systems and Information Management Section CloudSAMS

對齊(或排列)物件 – 方法二

45

◼ 1. 先開啟 File -> Options…
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對齊(或排列)物件 – 方法二

2. 再點選 Layout tab，於

“Grid options:” 調校

“Grid Size”至適合長度

(有效範圍 : 0.026–2.54   

cm)。

3. 調校至 0.026cm，然後

按確定，用鍵盤和滑鼠移

動物件位置時會更精細。

46
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對齊(或排列)物件 – 方法三

47

先點選要對齊的報告物件，再用工具列>格式>對齊 去執行
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使用醒目提示專家

48

按鈕或功能表 Format > Highlighting Expert
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隱藏不使用的區段 (section)

49

所有不使用的區段都應該隱藏
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工作台 (Workbench)

50



Systems and Information Management Section CloudSAMS

V. 如何刪除報表中的LOGIN ID: genuser

◼ 範本曾使用 “genuser” 連接Local Database作測試，
上載相關範本至CloudSAMS預覽，如出現Blank 

Report的情況，可根據以下方法檢查

51
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V. 如何刪除報表中的LOGIN ID: genuser

◼ 於範本<Database>選單下選擇<Set Database Location>檢查設定

◼ 在WebSAMS Connection下開啟<Properties>，如發現有使用者ID: genuser，
必須刪除

◼ 首先，點選使用者ID: genuser ，再按鍵盤上<F2>鍵，然後再按 <delete>
鍵，再按<Enter>鍵刪除

◼ 確定沒有 “genuser”後，就可以把範本儲存

52
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修改班別名單報告

熟習修改範本流程
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下載範本

54

請下載範本
R-STU005-C
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用 Crystal Reports 2020 開啟範本

55
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用 Crystal Reports 2020 預覽範本

56

1. 按 Print Preview 或 Refresh 按鈕或在功能表直接選
View > Print Preview 或在鍵盤按“F5"鍵

2. 在對話匣輸入以下的參數
(只適合於這個範本及本中心的 CloudSAMS 系統)：
◆ SUID: 9999 & (學校的 WebSAMS ID)

◆ SCHYEAR: 2024

◆ SCHLEVEL: 3 & (2:小學 3:中學)

◆ SCHSESSION: 3 & (1:上午 2:下午 3:全日)

◆ CLASSLEVEL: S3 & (Px代表小學 Sx代表中學)

◆ CLASSCODE: 3A &

◆ SUBJGROUP: ALL &

◆ Departed_Student_Printing: Exclude…

◆ 其他可以不輸入
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用 Crystal Reports 2020 預覽範本

57
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用 Crystal Reports 2020 修改範本

58

返回 Design 版面，修改如下圖後儲存
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上載範本至 CloudSAMS

59

在 CloudSAMS 的「報
告管理 > 範本 > 上載
範本」上載至同一個
報告名稱﹝編號﹞內

建議為上載的檔案建立
一個短且有顯而易見用
途的名稱。例如
AUTHOR_REPORTID

_USAGE_ENG.rpt
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在 CloudSAMS 預覽已修改的範本

60
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練習 (二)
製作學生名單

連接資料庫並提取所需資料
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開啟新報表及連接資料庫

62

開啟一個空白
的報告

雙擊
“Create New Connection”內
的選項“ ODBC (RDO) ”
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開新報表及連接資料庫

63

在 Data Source Name 選取

websams

* 1個伺服器安裝了2個網上校管系統
的學校，這裡除了會出現websams，
也會出現 websams2。上午校的報表
要選 websams，下午校要選websams2。
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開啟新報表及連接資料庫

64

在以下的位置找表格
TB_STU_STUDENT

Create New Connection



ODBC (RDO)



websams



wsadmin



Tables
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Crystal Reports 2020 版面

65

Field Explorer及五個 Sections
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插入資料欄位

將以下 TB_STU_STUDENT資料表中的欄位拖曳到
Details 區段內：
CLASSNO, CHNAME, ENNAME, DOB, SEX
*要讓欄位按字母次序排列，可以於功能表
File > Options 的 Database 版面選 Sort Fields Alphabetically
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用 Crystal Reports 2020 預覽範本

67
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篩選、排序、組合

68

◆ Select Expert (Report > Select Expert)：
篩選有 CLASSCODE 及 CLASSNO 不是 0 的學生

◆ Record Sort Expert (Report > Record Sort Expert)：
依 CLASSNO 排序

◆ Group Expert (Report > Group Expert) ：
以 CLASSCODE 作組合
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完成後的效果

69
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III. 如何修正資料錄排序

◆ 如果預覽時，報表的列印次序，跟之前不同，可以通過以下方法修改

◆ 雙擊打開Sub-Report (子報告)，按Record Sort Expert (資料錄排序專家) Icon 

(圖示)

70

方法一
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III. 如何修正資料錄排序 (續)

◆ 點選欄位 TB_HSE_COMMON.EN_DES (without _1)，再按 右箭咀>，移至
Sort Fields(排序欄位)

71
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III. 如何修正資料錄排序 (續)

◆ 點選Database Menu ，按Database Expert (資料庫專家) ，右擊 Table (資料
表) ，選取 ”Edit Command” (編輯命令碼) 

72

方法二
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III. 如何修正資料錄排序 (續)

◆ 修改 Command SQL，

加入“order by EN_ABBR, MO_EN_ABBR” 語句

73
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III. 如何修正資料錄排序 (效果)
◆ 例如，學期及考績比重清單 (R-ASR003-C) ，

修改後的效果

74

修改前 修改後效果
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III. 如何修正資料錄排序 (效果)
◆ 例如，學生特殊教育詳情報告 (R-STU202-C) ，

修改後的效果

75

修改前 修改後效果
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常用條件公式

◆ if … then … else

e.g. 

if {TB_STU_STUDENT.SEX} = 'M'

then '男'

else '女'

◆ select … case

e.g. 

select {TB_STU_STUDENT.SEX}

case 'M': '男'

case 'F': '女'

76
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部分常用函數 (Functions)

◆ totext() 把數字轉變為文字

◆ left() 選取字串中由左起的某部份

◆right() 選取字串中由右起的某部份

◆mid() 選取字串中某部份

◆ trim() 除去字串前後的空格

◆ isnull() 檢查欄位是不是空白

◆round() 把數字四捨五入致某部份

77
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部分常用運算子 (Operators)

Operator name Crystal Syntax Basic Syntax

Assignment (等於) := =

Add (加) x + y x + y

Subtract (減去) x – y x – y

Multiply (乘) x * y x * y

Divide (除) x / y x / y

Modulus (餘數) x mod y x mod y

EXP x ^ y x ^ y

Not Equal x <> y x <> y

Range less than x < y x < y 

Range Large than x > y x > y

Range less than or equal x <= y x <= y 

Range larger than or equal x >= y x >= y
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totext()

◆將數字轉作文字

◆e.g. 
假設 TB_ASR_RPTPSTUDENT.SCHYEAR = 2023

totext({TB_ASR_RPTPSTUDENT.SCHYEAR},'0') + '/' +

totext({TB_ASR_RPTPSTUDENT.SCHYEAR}+1, '0')

* '0' 代表不選取小數點後數字

效果：
2023/2024
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left()

80

◆ 傳回左面起指定的字串

◆ e.g. 

假設 TB_STU_STUDENT.HKID = A1234567 

left({TB_STU_STUDENT.HKID},4) + '****'

效果：
A123****
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right()

81

◆ 傳回右面起指定的字串

◆ e.g. 

假設 TB_STU_STUDENT.HKID = A1234567

'****' + right({TB_STU_STUDENT.HKID},4)

效果：
****4567
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mid()

82

◆ 傳回從某個位置起指定的字串

◆ e.g. 

假設 TB_STU_STUDENT.HKID = A1234567

'**' + mid({TB_STU_STUDENT.HKID},3,4) + '**'

效果：
**2345**
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trim()

83

◆ 去除字串的前後的空位

◆ e.g.

local stringvar name;

name := '     A.K. Wong         ';

'Dr. ' + trim(name) + ' (Principal)'

效果：
Dr. A.K. Wong (Principal)
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isnull()

84

◆ 測試欄位是否空值 (null)

◆ e.g.

if isnull({TB_STU_STUDENT.HKID})

then 'No ID Card No.'

else {TB_STU_STUDENT.HKID}

效果：
(沒身份證號碼) No ID Card No.

(有身份證號碼) A1234567

類似 Not 

applicate (N/A)
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round()

85

◆ 傳回四捨五入的數字

◆ e.g. 效果(原欄位之格式為三個小數點)

round(128.1683,2) 128.170

round(128.1683,1) 128.200

round(128.1683,0) 128.000

or round(128.1683)

round(128.1683, -1) 130.000
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使用公式 (formula)

1. Name :

{TB_STU_STUDENT.CHNAME} + ' (' 

+{TB_STU_STUDENT.ENNAME} + ')'

2. LastName :

left({TB_STU_STUDENT.CHNAME}, 1)

3. FirstName :

mid({TB_STU_STUDENT.CHNAME}, 2, 10)
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使用公式 (formula)

4. Position :

'第' + totext({TB_STU_STUDENT.CLASSCOL}, '0') + '行' + 

' 第' + totext({TB_STU_STUDENT.CLASSROW}, '0') + '個'

5. Sex :

if {TB_STU_STUDENT.SEX} = 'M'

then '男'

else '女'

6. HKID :

if isnull({TB_STU_STUDENT.HKID})

then '---'

else {TB_STU_STUDENT.HKID}
87



Systems and Information Management Section CloudSAMS

使用自訂的公式

◆刪除報表上原有資料庫欄位 SEX、ENNAME 及
CHNAME

◆將剛做好的公式拖曳至報表 Details 上
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練習 (三)
製作每月學生生日名單

(自學部份)

使用Group Expert
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